Delay in vote processing
Incident Report for reddit
Resolved
This incident has been resolved.
Posted 29 days ago. Apr 24, 2018 - 09:55 PDT
Investigating
Vote processing is delayed
Posted 29 days ago. Apr 24, 2018 - 09:00 PDT