Increased error rates
Incident Report for reddit
Resolved
This incident has been resolved.
Posted 7 months ago. Dec 07, 2017 - 15:41 PST
Investigating
We are currently investigating this issue.
Posted 7 months ago. Dec 07, 2017 - 12:29 PST