Modmail degraded
Incident Report for reddit
Resolved
This incident has been resolved.
Posted Jun 15, 2020 - 17:03 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 15, 2020 - 16:53 PDT
Investigating
We are currently investigating this issue.
Posted Jun 15, 2020 - 16:39 PDT
This incident affected: reddit.com (Modmail).