AWS availability causing degradation in user experiences for various services

Incident Report for Reddit

Identified

The issue has been identified and a fix is being implemented.
Posted May 07, 2026 - 19:52 PDT

Investigating

We are currently investigating some degradation in user experience which are being caused due to AWS issues in us-east-1
Posted May 07, 2026 - 17:47 PDT
This incident affects: reddit.com (Desktop Web, Mobile Web) and ads.reddit.com (Reddit Ads).