Investigating elevated errors and issues loading comments

Incident Report for Reddit

Resolved

This issue is now resolved. Errors have subsided and we're seeing consistent loading across comments.
Posted May 20, 2026 - 14:57 PDT

Monitoring

Most errors have cleared up and comments should be appearing as expected. We're continuing to monitor the situation.
Posted May 20, 2026 - 14:37 PDT

Identified

We've identified the issue and you should now start to see comments load properly again. We're still monitoring the situation!
Posted May 20, 2026 - 14:22 PDT

Update

We are continuing to investigate this issue.
Posted May 20, 2026 - 13:58 PDT

Investigating

We're currently investigating this issue. While this is ongoing, you may have trouble loading comment threads on www.reddit.com, and the native apps
Posted May 20, 2026 - 13:58 PDT
This incident affected: reddit.com (Desktop Web, Mobile Web, Native Mobile Apps, Comment Processing).