A fix has been rolled out and we have fixed the issues with impacted video posts.
Posted Dec 18, 2025 - 17:00 PST
Identified
We've identified and mitigated the underlying problem. Newly uploaded videos should now appear correctly, and we're working on a fix for videos uploaded during the outage.
Posted Dec 18, 2025 - 15:06 PST
Investigating
We are currently investigating reports that some video posts are displaying as images.
Posted Dec 18, 2025 - 14:49 PST
This incident affected: reddit.com (Desktop Web, Mobile Web, Native Mobile Apps).