Vote processing delay
Incident Report for reddit
Resolved
This incident has been resolved.
Posted Aug 15, 2020 - 12:19 PDT
Update
We are continuing to investigate this issue.
Posted Aug 15, 2020 - 12:19 PDT
Investigating
We are currently investigating this issue.
Posted Aug 15, 2020 - 11:26 PDT