Search errors
Incident Report for reddit
Resolved
We fixed the glitch. Please resume using our new and improved search.
Posted 9 months ago. Nov 02, 2017 - 15:26 PDT
Investigating
Search on reddit is currently broken. Investigating now.
Posted 9 months ago. Nov 02, 2017 - 14:37 PDT